This repository has been archived by the owner on Nov 25, 2020. It is now read-only.
forked from abhishekchopra13/nwoc_algorithms
-
Notifications
You must be signed in to change notification settings - Fork 52
/
Copy pathradix sort.cpp
95 lines (82 loc) · 2.28 KB
/
radix sort.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
// C++ implementation of Radix Sort
// Sample input:
//Enter the number of data element to be sorted: 4
//Element 1: 45
//Element 2: 96
//Element 3: 22
//Element 4: 61
// Sample output:
//Sorted data:
// 22 45 61 96
#include<iostream>
using namespace std;
// A utility function to get maximum value in arr[]
int getMax(int arr[], int n)
{
int mx = arr[0];
for (int i = 1; i < n; i++)
if (arr[i] > mx)
mx = arr[i];
return mx;
}
// A function to do counting sort of arr[] according to
// the digit represented by exp.
void countSort(int arr[], int num, int exp)
{
int output[num]; // output array
int i, count[10] = {0};
// Store count of occurrences in count[]
for (i = 0; i < num; i++)
count[ (arr[i]/exp)%10 ]++;
// Change count[i] so that count[i] now contains actual
// position of this digit in output[]
for (i = 1; i < 10; i++)
count[i] += count[i - 1];
// Build the output array
for (i = num - 1; i >= 0; i--)
{
output[count[ (arr[i]/exp)%10 ] - 1] = arr[i];
count[ (arr[i]/exp)%10 ]--;
}
// Copy the output array to arr[], so that arr[] now
// contains sorted numbers according to current digit
for (i = 0; i < num; i++)
arr[i] = output[i];
}
// The main function to that sorts arr[] of size n using
// Radix Sort
void radixsort(int arr[], int num)
{
// Find the maximum number to know number of digits
int max = getMax(arr, num);
// Do counting sort for every digit. Note that instead
// of passing digit number, exp is passed. exp is 10^i
// where i is current digit number
for (int exp = 1; max/exp > 0; exp *= 10)
countSort(arr, num, exp);
}
// A utility function to print an array
void print(int arr[], int num)
{
for (int i = 0; i < num; i++)
cout << arr[i] << " ";
}
// Driver program to test above functions
int main()
{
int num, i;
cout<<"\nEnter the number of data element to be sorted: ";
cin>>num;
int arr[num];
for(i = 0; i < num; i++)
{
cout<<"Enter element "<<i+1<<": ";
cin>>arr[i];
}
radixsort(arr, num);
// Printing the sorted data.
cout<<"\nSorted Data ";
for (i = 0; i < num; i++)
cout<<" "<<arr[i];
return 0;
}